Fiona 1.8.9 and GDAL 3


Sean Gillies
 

Hi all,

Lack of support from the fiona package for GDAL 3.0 has become unbearable. We won't make you wait for 1.9.0 and will instead have a 1.8.9 release that is compatible with GDAL versions 1.11 through 3.0. The planned release date is next Monday, 2019-10-21.

Please note that the wheels published to PyPI for 1.8.9 will contain GDAL version 2.4.2. If you require GDAL 3.0, you will need to install it separately and install the non-binary fiona package (like `python -m pip install --no-binary fiona fiona`) or use conda and install fiona from the conda-forge channel, which is more than ready to drop support for GDAL 2.x.

Switching the PyPI wheels over to GDAL 3.0 and PROJ 6.x is a bit of a lift and is not yet scheduled. It may be part of the 1.9.0 release.

Thanks for your patience!

--
Sean Gillies

Join main@fiona.groups.io to automatically receive all group messages.